Subject: Re: libssh2 MorphOS patch

Re: libssh2 MorphOS patch

From: Leif Salomonsson <>
Date: 04 Aug 2012 18:31:15 +0100

Hello Peter,

On 2012-08-04, you wrote:
> Hi!

> Leif Salomonsson wrote:
>> I will look into an alternative to using the macros, making a
>> linklib that encapsulates the macros for example.

> Will that work, given that the macros exist in some header file that
> presumably needs to be included?

I'm sure it would have.. but I just found out one can simply disable the
inline macros by a using define, so now it compiles just fine without any
name changes :) New patch attached.

>> > please at the very least use *sane* names
>> Sure. How about cb_send() and cb_receive() (cb_= callback). Now
>> we have actually improved the names because it becomes clear
>> they are not the same as bsdsocket send() and recv() (different
>> return values).

> Yes, this would be an excellent improvement. Would you please send
> that as a separate patch?


>> >> - if (session->remote.crypt->crypt(session, source,
>> >> + if (session->remote.crypt->_crypt_(session, source,
>> > Wouldn't you have to change the session->remote.crypt name as well?
>> No, GCC is OK with that, likely because "crypt->" is not a function
>> call.

> I guess it's #define crypt(foo) then, and CPP will only match the
> word including parenthesis.



Received on 2012-08-04